Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#399 closed Defect (fixed)

Poster chooser corruption

Reported by: wazza Owned by:
Priority: normal Milestone:
Component: Metadata - Posters Version: 1.0b8.0.5
Keywords: Cc:


I've noticed one film recently added to my collection was not imported.

There are no details in the logs (and no crash) other than

24/04/2011 18:38:48 Front Row[3042] Failed to import movie for /Users/******/Movies/How to Murder your Wife.avi 

During import there was no poster chooser step (chooser is not switched off in the settings). Checking IMDb shows there are no links for posters for this movie.

A dump of the SapphireMovieTranslation object associated with this search shows this:

On import:

24/04/2011 19:01:32 Front Row[3070] Translation <SapphireMovieTranslation: 0x14da5850>   {
    importerID = "";
    itemID = "";
    movie = nil;
    name = "how to murder your wife";
    otherProperties = nil;
    otherPropertiesData = nil;
    posters =     (
    selectedPosterIndex = nil;
    url = "";

All other times Sapphire starts up...

24/04/2011 18:38:47 Front Row[3042] Translation <SapphireMovieTranslation: 0x14de5d60> {
    importerID = "";
    itemID = "";
    movie = nil;
    name = "how to murder your wife";
    otherProperties = nil;
    otherPropertiesData = nil;
    posters = "<relationship fault: 0x1ea3d920 'posters'>";
    selectedPosterIndex = nil;
    url = "";

It seems to have faulted at some point in the poster choosing step, but this fault wasn't dealt with. After that things stop working as expected, itemID isn't set and the importer is helpless.

I've tried looking for where this might be happening, but I can't find it.

[Yes... I have updated the scrapers ;-)]

Change History (5)

comment:1 Changed 6 years ago by wazza


It's not the poster, it's the itemID, for some reason it's not finding an imdb ID.

The movie entry dictionary is

    ID = "";
    "IMDB Link" = "";
    name = "How to Murder Your Wife (1965)";

which looks like it's not getting all the details

comment:2 Changed 6 years ago by gbooker

(In [1340]) Allow one to reset import decisions even if the file isn't fully imported. Useful for import failures.
Refs #399

comment:3 Changed 6 years ago by gbooker

  • Resolution set to fixed
  • Status changed from new to closed

(In [1341]) Corrected IMDB import for titles that yield a single result.
Fixes #399

comment:4 Changed 6 years ago by gbooker

You'll likely need to delete that import Id. Since you were able to track it down this far, I'll assume you know how to delete an entry out of the SQLite database inside Library/Application Support/Sapphire/metaData.sapphireDataV3 Unfortunately, the currently released code's UI cannot delete the import decision for a file that didn't successfully import. With the committed scraper, I can import the movie, and its posters.

BTW, That's a good movie. It's been a few years since I've seen it.

comment:5 Changed 6 years ago by wazza

Yeah, that's fixed it. Cheers.

Note: See TracTickets for help on using tickets.